Challenges processing Airtime on Airtel network
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 13:38 EAT
Update
We are continuing to investigate this issue.
Posted Jul 26, 2024 - 13:36 EAT
Investigating
We are currently experiencing challenges processing Airtime on Airtel Nigeria network.

We are actively working on resolving the issue.

Sincere apologies for the inconvenience caused.
Posted Jul 25, 2024 - 13:36 EAT
This incident affected: Airtime.