Voice Service Outage in Tanzania

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted May 16, 2025 - 10:03 EAT

Update

We are continuing to work on a fix for this issue.
Posted May 16, 2025 - 10:03 EAT

Identified

The telco team have identified the issue. However, the restoration has taken longer than anticipated, but we are working tirelessly to ensure the services are restored.
Posted May 15, 2025 - 17:37 EAT

Investigating

We are currently investigating this issue and following up with the provider to have the service restored
Posted May 15, 2025 - 11:15 EAT
This incident affected: Voice.