Airtime service Intermitency on Airtel KE

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Jul 20, 2025 - 11:18 EAT

Investigating

Dear clients,

Airtel KE Airtime service is currently intermittent.
Posted Jul 19, 2025 - 21:12 EAT
This incident affected: Airtime.