Outgoing SMS Outage - Safaricom - Kenya

Incident Report for Africa's Talking

Resolved

The issue has been resolved on Safaricom side.
Posted Jun 30, 2025 - 11:45 EAT

Identified

We are currently experiencing an outage affecting delivery of SMS to Safaricom phone numbers.

This is due to a network issue on Safaricom's endpoints that is resulting in timeouts.

The issue has been escalated to Safaricom for resolution.
Posted Jun 30, 2025 - 08:33 EAT
This incident affected: SMS (Bulk).