Airtel airtime downtime - Kenya

Incident Report for Africa's Talking

Resolved

Transactions are now processing smoothly.
Posted Oct 01, 2025 - 08:29 EAT

Identified

The telco is experiencing challenges processing transactions.

They are working to restore the service.

Sorry for the inconvenience.
Posted Sep 30, 2025 - 21:45 EAT
This incident affected: Airtime.