Challenges with Airtime delivery on Airtel Kenya network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted May 13, 2026 - 13:15 EAT

Identified

Dear Client,

We are currently experiencing airtime delivery issue on Airtel KE network.

We are actively working to resolving the issue.

Apologies for the inconvenience caused.
Posted May 13, 2026 - 13:03 EAT
This incident affected: Airtime.