Challenges processing Airtime on Telkom Kenya Network
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Aug 19, 2024 - 20:33 EAT
Identified
We are currently experiencing challenges processing Airtime on Telkom Kenya network

We are working on resolving the issue as soon as possible

Apologies for the inconvenience caused.
Posted Aug 19, 2024 - 12:24 EAT
This incident affected: Airtime.