Airtime service Downtime on Safaricom network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 08:36 EAT

Identified

Dear Client,

We are currently experiencing service downtime on Safaricom Airtime service. This is as a result of the telco issue affecting posting of orders on the dealer accounts across all the providers.

The team is actively working on resolving the issue.

Apologies for the inconvenience caused.
Posted Jun 10, 2025 - 22:11 EAT
This incident affected: Airtime.