Service Advisory | Downtime on USSD; MTN Rwanda
Incident Report for Africa's Talking
Resolved
We're now receiving USSD traffic from MTN.
Posted Jul 24, 2024 - 12:17 EAT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2024 - 16:59 EAT
Investigating
We are currently experiencing an outage. We're working closely with the telco to restore the service.
Posted Jul 23, 2024 - 15:50 EAT
This incident affected: USSD.