Service Degradation for Voice on 0708... series in Nigeria

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Apr 02, 2026 - 13:27 EAT

Identified

Dear client,

We are facing Service Degradation for Voice in Nigeria affecting the 0708..series. Our team is closely working with their provider to resolve the issue

Apologies for the inconvenience caused
Posted Apr 01, 2026 - 15:54 EAT
This incident affected: Voice.