Challenges with Airtime Delivery on Airtel Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 09:51 EAT

Identified

We are currently experiencing airtime delivery on Airtel Kenya network.

The issue has been identified and escalated to the telco team for resolution

Apologies for the inconvenience caused.
Posted Feb 12, 2026 - 08:23 EAT
This incident affected: Airtime.