Safaricom Outgoing SMS Outage

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 18:46 EAT

Identified

We are currently experiencing an outage on Safaricom SMS Gateway that's affecting termination of messages to users.

The issue is currently being addressed by Safaricom Engineering team.

We will share an update shortly.
Posted Oct 09, 2025 - 11:29 EAT
This incident affected: SMS (Bulk).