Service Outage

Incident Report for Africa's Talking

Resolved

The issue has been resolved. Thank you for your patience.
Posted Sep 04, 2026 - 17:13 EAT

Identified

We are currently experiencing service interruptions for the following:

USSD and Airtime - Safaricom Kenya
USSD - Airtel Kenya
USSD - Equitel Kenya
USSD - Telkom Kenya
Airtime - Telkom Kenya
Airtime - MTN Uganda
SMS - Moov CIV
USSD and Airtime - Airtel Nigeria
USSD and Airtime - Globacom Nigeria
USSD - Airtel Malawi
USSD and SMS - TNM Malawi
USSD - Airtel, Yas, Vodacom Tanzania
USSD - MTN and Glo Nigeria
Airtime - MTN, Zamtel Zambia
Airtime - Glo Nigeria
Payments (M-Pesa Top ups) - Safaricom Kenya

Our team is actively working on resolving the issue.
Posted Sep 04, 2026 - 16:49 EAT
This incident affected: SMS (Bulk) and Airtime, USSD.