Intermittent Service Delivery for Voice in Kenya
Incident Report for Africa's Talking
Update
We are continuing to engage with the telco to resolve this issue.
Posted Aug 27, 2024 - 12:01 EAT
Investigating
We are currently investigating this issue.
Posted Aug 24, 2024 - 12:21 EAT
This incident affects: Voice.