USSD Downtime - South Africa
Incident Report for Africa's Talking
Resolved
The service has been restored.
Posted Nov 18, 2024 - 17:00 EAT
Identified
We are currently unable to process USSD requests in South Africa. We are actively working to restore the service.
Posted Nov 18, 2024 - 15:11 EAT
This incident affected: USSD.