Delays in processing airtime on Airtel KE network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Nov 07, 2024 - 10:14 EAT

Identified

We are currently experiencing delays in processing Airtime on Airtel Kenya network.

We are working on resolving the issue soonest.

Apologies for the inconvenience caused.
Posted Nov 07, 2024 - 08:08 EAT
This incident affected: Airtime.