Service Downtime

Incident Report for Africa's Talking

Resolved

This issue has been resolved.
Posted Feb 18, 2026 - 00:47 EAT

Identified

We are currently experiencing service interruptions for the following:

USSD and Airtime - Safaricom Kenya
USSD - Airtel Kenya
USSD - Equitel Kenya
Airtime - Telkom Kenya
Airtime - MTN Uganda
SMS - Moov CIV
USSD and Airtime - Airtel Nigeria
USSD and Airtime - Globacom Nigeria
USSD - Airtel Malawi
USSD and SMS - TNM Malawi
USSD - Airtel Tanzania
USSD - Yas Tanzania
USSD - Vodacom Tanzania
Airtime - MTN Zambia
Airtime - Zamtel Zambia

Our team is actively working on resolving the issue.
Posted Feb 17, 2026 - 17:45 EAT
This incident affected: SMS (Bulk) and Airtime, USSD.