Service outage- Airtel KE network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 20:49 EAT

Identified

We are currently experiencing Airtime service outage on Airtel Kenya network.

The team is actively working on resolving the issue.

Apologies for the inconvenience caused.
Posted Mar 24, 2025 - 19:08 EAT
This incident affected: Airtime.